最新消息:

易语言通过注册表卸载程序例程

例程 永恒心锁 3065浏览 0评论
.版本 2
.支持库 spec

.程序集 窗口程序集1

.子程序 __启动窗口_创建完毕
.局部变量 NSIS, 文本型

NSIS = 取文本注册项 (4, “SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\NSIS\UninstallString”, )
.如果真 (NSIS ≠ “”)
 NSIS = NSIS + “uninst.exe”
 .如果 (信息框 (“您电脑里有安装NSIS,,请确认卸载!”, 1 + #警告图标, “卸载NSIS例程”, ) = #确认钮)
 运行 (NSIS, 假, )
 结束 ()
 .否则
 信息框 (“您未卸载软件,程序将结束”, #信息图标, “信息”, )
 结束 ()
 .如果结束

 调试输出 (NSIS)
.如果真结束

免责声明:根据《计算机软件保护条例》第十七条规定“为了学习和研究软件内含的设计思想和原理,通过安装、显示、传输或者存储软件等方式使用软件的,可以不经软件著作权人许可,不向其支付报酬。”您需知晓本站所有内容资源均来源于网络,仅供用户交流学习与研究使用,版权归属原版权方所有,版权争议与本站无关,用户本人下载后不能用作商业或非法用途,需在24个小时之内从您的电脑中彻底删除上述内容,否则后果均由用户承担责任;如果您访问和下载此文件,表示您同意只将此文件用于参考、学习而非其他用途,否则一切后果请您自行承担,如果您喜欢该程序,请支持正版软件,购买注册,得到更好的正版服务。丨本站为个人博客非盈利性站点,所有软件信息均来自网络,所有资源仅供学习参考研究目的,并不贩卖软件,不存在任何商业目的及用途。丨本文采用知识共享 署名4.0国际许可协议 [BY-NC-SA] 进行授权BY-NC-SA协议进行授权

转载请注明:永恒心锁-分享互联网 » 易语言通过注册表卸载程序例程

与本文相关的文章

  • 暂无相关文章!
发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址